Monat: August 2013

BMS läuft

Nach einigen Fahren, hab ich die Zellen durchgemessen. Die Schwankungen waren zwischen 3,114V und
1,342V. Vollständig leer.
Es muss also das BMS irgendwie laufen. Also habe ich nach Wochen einen neuen Anlauf genommen die CAN Module zu laufen zu
bekommen. Mit hohen bitpro sekunde Raten sah ich zumindest zwei Module, dann wieder nicht. Den entscheidenen Tip gab mir
Hanno mit seinem Z3. Das habe ich ausprobiert und es nun zum laufen bekommen.
Mehr hier auf diesem Thread: http://26373.foren.mysnip.de/read.php?567,363662,377821#msg-
377821.
Am Wochenende habe ich mich dann weiter ums Haus gegraben udn ein Kabel 5×2,5mm² und zwei Steuerleitungen 1,5mm² versenkt. Idee ist alle Elekronik im Schaltkasten zu haben und aussen nur das Ladekabel. In den Sicherungsschrank kommt neben den Sicherungen ein Drehstrommesser mit Wattmeter und ein Drehstromschütz mit einer 12V Spule die dann das Ladekabel freischaltet. Zur Steuerung denke ich über einen Arduino Nano im Hutschienengehäuse nach. Könnte funktionieren.
Vor allem sehe ich dann im Haus, ob und wieviel geladen wird. Bei unseren Wintern nicht ganz unwichtig… Mehr wenns fertig ist.

CFK Fahrwerkteile

Entwicklung des weltweit ersten CFK Fahrwerkstabilisator für IFA.
Erster Einsatz in der Kleinserie VW XL 1.
Als gebaute Variante auch im Bugatti Chiron.

und noch leiser

Trotz des wechseln der Dämpfer gab es noch ein zweites Quitschen. Das kam aus dem Traglager des Federbeines unten. Das ist nun auch weg; erst einmal durch Nachschmieren, ich werde es aber wohl noch mal auswechseln.
Dann habe ich mir noch eine Tageszulassung geholt und bin zum Porsche Zentrum gefahren um dem Problem des ABS Fehlers näher zu kommen. Nach einer Schrecksekunde warum man denn den Motor durch einen Elektromotor ersetzt, ergab das Auslesen des ABS das ihm das CAN Bus Signal des Verbrennungsmotors fehlt. Das ABS ist ein Bosch 5.7 was auch ins Motormanagement eingreift,
Porsche schlägt vor auf 5.3 zurückzurüsten… Oh je
Dann bin ich auf eine Waage gefahren: Vorderachslast 600kg, Hinterachslast 750kg. Mit 1350kg ist der Wagen somit nur 15kg schwerer als Serie. Es fehlt aber noch der Ersatzreifen.

Es wird leiser

Ein paar Neuigkeiten. Die Tankuhr funktioniert nun exakt. Ein paar Einstellungen am Emus und SOC und Tankuhr passen ziemlich gut. Komisch eigentlich. Es gibt ja keine Verbindung zur Batterie. Ich denke es wird aus der Einstellung 200Ah errechnet zusammen mit dem Strommesser.
Ich kämpfe seit längerem damit Daten vom EMUS und Curtis via MAX 232 Chip an den Arduino zu bekommen. Es funzt nicht. Keine Ahnung warum. Ich habe versucht die Daten mittels 232/USB Kabels auszulesen, aber auch dort keinen Erfolg. Keins von zwei Kabeln funktioniert.
Ob dieser Niederlagen, habe ich dann erst mal die quitschenden Stossdämpfer vorne ausgewechselt. Diese reine mechanische Arbeit ist dagegen simpel.
Nun aber ist das Auto leiser.
Es gibt noch einen Fehler des nicht funktionierenden ABS. Dazu dann noch ein USB OBD2 Kabel besorgt, um den Fehler zu lokalisieren oder zu löschen,
aber auch das bekomme ich nicht zum laufen. Ach waren das noch schöne Zeiten mit RS232 Schnittstellen!
Dann möchte ich noch meine Lademöglichkeit, von einem provisorisch verlegtem Kraftstromkabel etwas sicher machen. Dazu
muss ein Kanal ums Haus gegraben werden in das ein Erdkabel verlegt werden muss. Anstrengend.

Niederlage und Erfolg liegen doch so eng beieinander…

Es ist einiges passiert. Zuerst habe ich die Heizungsteuerung nochmal überarbeitet bekommen (siehe letzter Post).
Dann habe ich die kaputten CAN Module des BMS zurückbekommen. Eingebaut, und sie funktionieren immer noch nicht. Inzwischen kenne ich schon vier Umbauer mit mittelschweren Problemen mit den EMUS BMS. Also egal, und erst mal ohne BMS weiter.
Dann habe ich das Arduino mit dem Hauptdisplay eingebaut. Es hat inzwischen 2 serielle Eingänge für die ich einen MAX232 verwende, der mir die Signale in Arduino verständliche TTL Signale umwandelt. Sobald ich die Signale vom Curtis gelesen bekomme, gibts auch ein wenig Code und Bilder.
Dann habe ich angefangen an der TÜV Doku zu arbeiten. Als Basis dient das TÜV Merkblatt 764.
Zusätzlich brauche ich auch eine Rettungskarte, die ich an die Rettungskarten der aktuellen Porsche Hybrid angelehnt habe. Schon komisch ein 3 seitiges Dokument!, wer liest sich das denn im Rettungsfall durch? Und was nützt ein Dokument im Auto, in dem dann steht, dass wenn das Fahrzeug im Wasser versenkt ist, an der Karrosserie Hochstrom anliegen kann? Wenns sein soll…
Zu guter letzt dann Kurzzeitkennzeichen besorgt und gefahren! Gestern 10 km bis ich liegenblieb mit leeren Batterien. 157Ah nachgeladen und heute dann 98km weit nicht gerade langsam über Landstraßen geräubert. Alles funktioniert. Die Steuerelektronik der Servolenkung habe ich auf abschalten ab 80km eingestellt analog der ECE R79 für Lenkungen. So fährt es sich auch richtig gut.
Zwischenzeitlich zeigte auch die Tankanzeige was an. Hierzu ist bei den modernen Tankanzeigen an einem Kabel 5V (hier orange) am anderen (lila) geht das Signal dann zum Instrumentencluster. Das BMS direkt anschließen ging nicht, aber Vehikelfranz gab mir den Tip einen NPN Transistor dazwischenzuschalten also orange in den Transistor lila raus aus dem Transistor und das BMS an
den Emitter. Das geht.
Am nervigsten ist ein quitschendes Federbein. Beim Verbrenner würde das wahrscheinlich kaum auffallen, so aber hört es sich wie eine schlecht geölte Kutsche an.
Dennoch es fährt, mal sehen was noch mit der Reichweite geht…
Update es geht einiges! Gestern habe ich endlich vollgeladen, dann heute insgesamt 80km
gefahren. 1/3 Autobahn mit 130km/h, 1/3 Landstraße mit 100 und 1/3 Stadt mit 60km/h. Batterie war
danach noch 40% voll, also ca. 130km Reichweite.