BMS

BMS läuft

Nach einigen Fahren, hab ich die Zellen durchgemessen. Die Schwankungen waren zwischen 3,114V und
1,342V. Vollständig leer.
Es muss also das BMS irgendwie laufen. Also habe ich nach Wochen einen neuen Anlauf genommen die CAN Module zu laufen zu
bekommen. Mit hohen bitpro sekunde Raten sah ich zumindest zwei Module, dann wieder nicht. Den entscheidenen Tip gab mir
Hanno mit seinem Z3. Das habe ich ausprobiert und es nun zum laufen bekommen.
Mehr hier auf diesem Thread: http://26373.foren.mysnip.de/read.php?567,363662,377821#msg-
377821.
Am Wochenende habe ich mich dann weiter ums Haus gegraben udn ein Kabel 5×2,5mm² und zwei Steuerleitungen 1,5mm² versenkt. Idee ist alle Elekronik im Schaltkasten zu haben und aussen nur das Ladekabel. In den Sicherungsschrank kommt neben den Sicherungen ein Drehstrommesser mit Wattmeter und ein Drehstromschütz mit einer 12V Spule die dann das Ladekabel freischaltet. Zur Steuerung denke ich über einen Arduino Nano im Hutschienengehäuse nach. Könnte funktionieren.
Vor allem sehe ich dann im Haus, ob und wieviel geladen wird. Bei unseren Wintern nicht ganz unwichtig… Mehr wenns fertig ist.

Niederlage und Erfolg liegen doch so eng beieinander…

Es ist einiges passiert. Zuerst habe ich die Heizungsteuerung nochmal überarbeitet bekommen (siehe letzter Post).
Dann habe ich die kaputten CAN Module des BMS zurückbekommen. Eingebaut, und sie funktionieren immer noch nicht. Inzwischen kenne ich schon vier Umbauer mit mittelschweren Problemen mit den EMUS BMS. Also egal, und erst mal ohne BMS weiter.
Dann habe ich das Arduino mit dem Hauptdisplay eingebaut. Es hat inzwischen 2 serielle Eingänge für die ich einen MAX232 verwende, der mir die Signale in Arduino verständliche TTL Signale umwandelt. Sobald ich die Signale vom Curtis gelesen bekomme, gibts auch ein wenig Code und Bilder.
Dann habe ich angefangen an der TÜV Doku zu arbeiten. Als Basis dient das TÜV Merkblatt 764.
Zusätzlich brauche ich auch eine Rettungskarte, die ich an die Rettungskarten der aktuellen Porsche Hybrid angelehnt habe. Schon komisch ein 3 seitiges Dokument!, wer liest sich das denn im Rettungsfall durch? Und was nützt ein Dokument im Auto, in dem dann steht, dass wenn das Fahrzeug im Wasser versenkt ist, an der Karrosserie Hochstrom anliegen kann? Wenns sein soll…
Zu guter letzt dann Kurzzeitkennzeichen besorgt und gefahren! Gestern 10 km bis ich liegenblieb mit leeren Batterien. 157Ah nachgeladen und heute dann 98km weit nicht gerade langsam über Landstraßen geräubert. Alles funktioniert. Die Steuerelektronik der Servolenkung habe ich auf abschalten ab 80km eingestellt analog der ECE R79 für Lenkungen. So fährt es sich auch richtig gut.
Zwischenzeitlich zeigte auch die Tankanzeige was an. Hierzu ist bei den modernen Tankanzeigen an einem Kabel 5V (hier orange) am anderen (lila) geht das Signal dann zum Instrumentencluster. Das BMS direkt anschließen ging nicht, aber Vehikelfranz gab mir den Tip einen NPN Transistor dazwischenzuschalten also orange in den Transistor lila raus aus dem Transistor und das BMS an
den Emitter. Das geht.
Am nervigsten ist ein quitschendes Federbein. Beim Verbrenner würde das wahrscheinlich kaum auffallen, so aber hört es sich wie eine schlecht geölte Kutsche an.
Dennoch es fährt, mal sehen was noch mit der Reichweite geht…
Update es geht einiges! Gestern habe ich endlich vollgeladen, dann heute insgesamt 80km
gefahren. 1/3 Autobahn mit 130km/h, 1/3 Landstraße mit 100 und 1/3 Stadt mit 60km/h. Batterie war
danach noch 40% voll, also ca. 130km Reichweite.

BMS läuft, Controller läuft, kleinere Problemchen, wird aber…

Nachdem ich nun Ersatz für die beiden defekten CAN Module bekommen habe, läuft auch das BMS Modul. Mit der Schnittstelle zum Tacho bin ich auch weiter. Dank Vehikelfranz‘ Hilfe habe ich eine mögliche Lösung gefunden. Das muss nun aber noch verlötet werden,
wozu aktuell die Zeit fehlt. Kommt also noch. Sobald sich eine funktionierende Lösung auftut, werde ich die auch posten. Nicht funktioniernende habe ich nun genug, würden hier aber nur zur Nebelbildung dienen.
Die Stromversorgung zum BMS muss ja ständig laufen, tat sie auch. Das Auto schaltet aber nach 2 bzw. 5Tagen viele Verbraucher aus, darunter auch den Kreis fürs BMS. Darauf musste ich erst kommen. Jetzt hängt es über eine 2A Sicherung direkt an der Batterie.

Einbau Batterie

Batterie mit Heizung

Es wird Zeit mit den Batterien weiter zu kommen. Also habe ich zuerst in die Kästen eine Batterieheizung eingebaut.
Dazu habe ich eine 200W elektrische Fußbodenheizung zerlegt und die gut 16m Heizkabel an den Wänden der Batteriekästen mit Aluklebeband in ca
6-7cm Abstand angeklebt.
Unter den Batterien habe ich mich nicht getraut Heizkabel einzusetzen. Trotz des ganz engen Verbaus, könnte ich mir vorstellen, dass es zu kleinen
Bewegungen kommen könnte, die die Kabel beschädigen.

Links ein Bild des vorderen Schaltkastens: Links oben die Übergabestelle für 380V Rechts 2 12V Relais für Lader und Batterieheizung.
Beide werden vom BMS gesteuert.
Rechts unten ein Kilovac 200 für die elektrische Innenraumheizung. Das Kilovac ist vielleicht ein bischen groß, aber ich hab das günstig aus Hongkong
bekommen. Links daneben der Masseübergabepunkt für Lader, Heizung und Batteriemasse. Ihr seht da noch die provisorische Lüsterklemme für 220V um die Batterieheizung zu testen.
Anschließend habe ich die Batterien final angefangen einzubauen. Angefangen deshalb weil wieder etwas nicht so wollte. Wie immer halt: Der Bau eines E-Autos ist das Lösen von vielen kleinen Problemen…

Schaltkasten vorn

Lader und Controller

Layout der Batterie

Da es langsam kalt wird ist wieder die Überwindung größer am Auto zu arbeiten.
Dennoch habe ich im vorderen Kofferraum und den Lader an die Mulde nach vorne hin angeschraubt. Ich hatte das Gefühl die Verkabelung muss weitergehen also hab ich in den vorderen Kofferraum dann die Spritzwand zur Batterie vorne hin eine Schaltbox eingebaut. Versehen mit einer DIN Schiene findet sich da der
Starkstromübergang, zwei Relais, davon eins zum Schalten des Laders und eins zum Schalten der Batterieheizung.
Daneben passte dann noch ein Kilovac zum schalten der Innenraum-Heizung. Die beiden 12V Relais werden vom EMUS BMS gesteuert, dass ich auch am hinteren Batteriekasten angebracht habe.
So konnten langsam die ersten Kabel von vorn nach hinten laufen 2x 70mm² für die Batterie, 2x25mm² für den Lader (damit habe ich auch Batteriespannung
vorn), und 3×1,5mm² für die Batterieheizung die auf 220VAC läuft.
Diese Kabel laufen alle im Tunnel, wo vorher die Kühlwasserleitungen liefen.
Die konnen sogar wiederverwendet werden.
Etwas platt gedrückt und orange lackiert halten sie die Leiten ziemlich gut und EMV optimiert (hoffe ich).
Zum auftrennen der Batterie hab ich einen 1500A Trennschalter hinter dem Beifahrersitz angeordnet. Der trennt die Batterie ziemlich in der mitte.
Die Kühlplatte für den Controller ist vorgestern auch von EV West angekommen. So konnte ich nun auch den Controller final verschrauben.